My Series III is in Edmonton!

Tell all about your Lazair
Post pics --
After a while we wil streamline the forums and see what is most popular.
Want you own forum ? Let us know.

Postby JPXman » Sun Aug 08, 2004 9:36 pm

Hi everyone!

Just a quick note to say that thanks to the lazair network of excellent people, I have been reunited with my lazair and trailer after it was brought 4000km to me by another lazairhead. Thanks so much to Alan and Rob Kerr, Dave Herron, Karl Petrouch, and Marc Bourdon for making it all possible, and thanks to all the others who offered to help me in one way or another to move it across the country!

I will begin work now on getting two serviceable engines running, and then taking to the skies over Alberta. Hopefully it will not take too long!

Keep the rubber side down,

Tyler
User avatar
JPXman
LazairNUT
 
Posts: 625
Joined: Sun Nov 02, 2003 10:15 pm

Postby rayjb60 » Tue Aug 10, 2004 1:30 am

Wow...4000km....were did you leave it? Mexico.

Its good to know that we support each other....Thumbs up to all the great Lazairheads who helped.

Good luck Tyler.....get that baby airborne and keep us posted.

Once Im in the air in the next couple months I'll be taking the digital Camera along and letting you guys see California...low and slow.
<H5>Nothing is impossible...Even the word tells you Im-Possible!!!</ H5>
User avatar
rayjb60
LazairNUT
 
Posts: 235
Joined: Tue Jun 15, 2004 2:49 pm
Location: Lake Elsinore, CA

Postby JPXman » Fri Apr 21, 2006 2:21 am

Well it only took 20 months and a lot of work, but I think I can finally call C-IJCP "rebuilt". That is of course after the 14 months i rebuilt it in Ontario before moving it to alberta ;)

I will post a picture once my camera is recharged, but Myles and I went out to the field tonight and I got to just fly around after putting the final tweaks on the carbs, installing the wheel pants, and swapping out some old parts.

All in all, I am jazzed. I will call it a series IIIEC as it does not have every Elite modification. man does it move. Full power on the JPX's with 34x20 props, level flight at 3400 ASL, I indicate 66mph on a pitot-type ASI (factory Orbit Lazair ASI), and that's pretty accurate backed up with my GPS doing upwind and downwind passes. Climb rate isn't the best, 300fpm at best, but i'm weighing in at 260 pounds these days and the plane is around 350 I figure.

If I'm not careful on the descent, it speeds right up to 70mph! that EC really lets it slip through the air.

Pictures to follow.

Tyler

PS: big thanks to Myles (daffy) for all his unending help over the past 2 years, thanks buddy, now lets get your EC in the air and start the first lazair pylon racing team.
You do not have the required permissions to view the files attached to this post.
User avatar
JPXman
LazairNUT
 
Posts: 625
Joined: Sun Nov 02, 2003 10:15 pm

Postby JPXman » Tue Apr 25, 2006 1:47 am

so no sooner do i go for my first "hassle free" flight than I end up also doing my first "which farmers field shall i use for my first forced landing" :)

Yep, planted the lazair nicely into a field of fresh cow patty's :) no damage, just a nice one hour push between landmines back to a fence to get back to airport property. The left engine quit right at the sweet spot on takeoff we all love to look fondly back on as we pass it - well i was nice and personal with that moment yesterday :)

Found out that heavy me, heavy lazair and one JPX running at 4400rpm gives me 100'/min down, no climb whatsoever :) i need bigger props :)

Tyler

PS: I wish i had a picture, but i'll take one from the air next time to describe the scene of the crime
User avatar
JPXman
LazairNUT
 
Posts: 625
Joined: Sun Nov 02, 2003 10:15 pm

Postby Guest » Tue Apr 25, 2006 12:42 pm

What caused the engine failure ?
Guest
 

Postby Guest » Tue Apr 25, 2006 1:03 pm

What caused the engine out ?
Guest
 

Postby Guest » Tue Apr 25, 2006 1:21 pm

What caused the engine out ?
Guest
 

Postby JPXman » Tue Apr 25, 2006 9:09 pm

my suspicion is fuel starvation due to an emptying fuel bowl on the dell'orto carb, either by a bad venting strategy, a malfunctioning fuel pump (20 years old), or some combination of air bubbles in the lines/leaks.

let the games begin

Tyler
User avatar
JPXman
LazairNUT
 
Posts: 625
Joined: Sun Nov 02, 2003 10:15 pm

Postby uscgairdale » Wed Apr 26, 2006 5:57 am

Tyler, glad to hear that you are ok....and your EC too. It would have sucked for you to put all that time and effort into it and lose it all on the first flight.

You do know that you're not allowed to ever crack it up because EC's are hard to find, right? (ha ha)

Dave
User avatar
uscgairdale
LazairNUT
 
Posts: 479
Joined: Thu Dec 02, 2004 2:30 pm
Location: Camden, NC

Postby daffy1029 » Wed Apr 26, 2006 6:36 pm

Hi Tyler,
Or maybe old points, condenser, or coils? :rolleyes:
Daffy
daffy1029
LazairNUT
 
Posts: 168
Joined: Sat Feb 21, 2004 12:17 am

Next

Return to Pilots Lounge

Who is online

Users browsing this forum: No registered users and 7 guests

cron